Anchors broken on Chrome PC and Mac

Hi, I am having trouble with the anchors on my website not working when I publish to Chrome. They are working fine in preview in Chrome and fine in Safari/iPad/iPhones (preview and published). This is happening both in PC (windows 10) and Mac (Catalina) I searched and it sounds like this may be a Chrome bug? Anyone have a workaround?

LOVE sparkle app btw :slight_smile:

Do you have a sample site showing that?

Hi Duncan, Thanks for checking in. I do but don’t feel comfortable posting it because of client confidentiality (it includes unreleased financial info).

Email us at perhaps?

thanks, Duncan I just emailed you.

Just to give feedback on my end with this issue…
I’ve got the latest Chrome (Version 84.0.4147.89 (Official Build) (64-bit)) on Catina and several sites out in the wild with anchor points and testing them all just then, all works fine.

I haven’t tried on Windows 10 though.

EDIT / UPDATE : I have just tried a few of my sites with anchor points on Windows 10 Chrome (the latest to date) and all sites are working correctly as should.

@kcapraro, Do you have the very latest Chrome onboard for Catina and Windows 10?

Hi, I had a similar problem sometime ago with Safari and Chrome.

Do make sure your browser cache is cleared. If that does not work try restarting your router.

It was only by looking at the source code of the pages I was being served that I was able to detect the cause of the missing anchors (the only change made compared to the previous version of the site), which was my router was serving locally cached older versions of the pages. Restarting the router fixed the problem (never did find out what the root cause of the problem at the router was!)

The support centre solution of “turn everything off and back on again” is there because sometimes it works!