Disable Autosave?

Hello,

is there any way I can prevent Sparkle from automatically saving my document?

Many thanks.

Greetings

Hello.

I think this is in MacOS. You can try after reading this website.

Mr. F.

1 Like

You can turn off versions globally by checking this checkbox in the macOS System Preferences, general section:

image

To disable document versions for just Sparkle you need to use the Terminal, and enter this:

defaults write eu.riverdesign.sparkle ApplePersistence -bool no

1 Like

Many Thanks! Unfortunately, the workarount does not work via the terminal. As soon as I make a change in my web project, it is automatically saved in the Sparkle Projektfile.

Saving takes place immediately after every change, not only when closing sparkle!

Sorry for my bad english.

macOS = Big Sur + Sparkle = Version 3 (German)

The System Preferences checkbox does work. It is likely that you need to close and reopen Sparkle.

Autosave is a system feature, that’s why the setting is in the System Preferences, and yes it saves some time after a change, or when switching to a different application. Sparkle only responds to the system asking for the file for the currently open project, we don’t control and can’t affect the policies on how it’s done.

1 Like

Thank you for the great help. That helped me :+1: