Double image on opening page

This one is odd. Doesn’t show up on preview and I can’t seem to see it on the sparkle canvass.
I’ve got a double image, and can’t seem to figure out why. Perhaps I have a stretched image, on top of an image for my 320px device that I’m showing on all devices?
I’ll take a shot of the program image as well. Thanks in advance.


Hi Bill.

That’s weird.
Have you checked the layer panel on the left?
There you see what you have on the page: black = visible; gray = hidden

Or do you have an external content placed somewhere with the big background image?

Mr. F.

Found it Mr. F. I had created a smaller image of the tractor on the 320px device, that was also showing on the front page.
Im getting mixed up between “show on this device” and “show on this page”

  • W

@Mr_Fozzie Nope. I still don’t have it. I need a good primer on “don’t show” and “show” on pages.
In the 960 variant each header image is a full width image, a different image for each page. With a show on this page only, on this device only.
I then move to the 320 and use the same header image, but I chose to squeeze it down to fit the 320, with show in this page only.
I doing something wrong in the workflow, because I’m still getting the 320 image on top of the hero image on the 960 page.
I’m reviewing the documentation but can’t find the section on “show on page options” I’m stuck.

Hello Bill.

Without having the project file “in hand” it’s hard to tell. You are aware of the little eye icon (top left)?

Show on this page only: means this page, like index.html, no other page, but on all devices
Show on this device: :ballot_box_with_check: is set by default for all devices. You need to switch to a different device (from 960 to 320 f.e.) and uncheck the box. Then this element disappears on the selected device.

Use the eye icon to check out.
And have a look in the layer panel.
Documentation: Arrange | Sparkle Documentation

Mr. F.

1 Like