Email forms not working

Just when I thought I could take a break, I realised that my email form is working. I tried the mail-tester.com and no email is coming through there either.

Then I checked my other Sparkle sites and they’re not working - one of the sites is HERE. It was working previously but I’m not sure when that stopped as the emails are forwarded to the church administrators. It’s only when I did a test email last night and checked the cpanel mail box that I realised it is no longer working.

My host is Bluehost. I contacted them but they said that because my site isn’t Wordpress, they can only give me limited assistance. Very disappointing.

Any ideas on what I can do? Are there other Bluehosties out there with similar issues?

Many thanks AGAIN!

Sorry, the website where the form is not working is http://www.yumchamama.com and the Coptic site as above.

@jazzbird, From what I see you have it set up correctly, but I’ve noticed both your sites are running “http” which has become a big no no nowadays plus some hosting services are blocking emails without the mandatory security layer - SSL Certificate, aka “https”.

I would say this is the issue…

Hello again @greenskin. I had a check of my hosting account and apparently it is set up with the SSL Certs so I am very confused. I’ll contact the customer service again but they don’t seem very keen to help non-WP folks. I’m quite surprised! Thank you again!

@jazzbird, Ok if you have them assigned (the SSL Certificates) then they aren’t being forced which you can do in your cPanel by permanently redirecting (301) all http onto https

Oh and it might be time to find another host if they are anti-everything except WordPress! :frowning:

1 Like

Hello! I am now fully https on all my three sites. But still no luck with email form via server. I find this odd as when I built my last site not all that long ago, the form worked a treat. Now suddenly none are working.

Any more thoughts? Anyone?

Can you show a screenshot of the button settings?

Sounds familiar… I had the similar issue, that mysteriously fixed itself after hours on the phone with Godaddy.

Thank you @duncan. I’m really at a loss here. As previously mentioned, I’ve never had issues before then this.

Hi @jazzbird, so you just need to click that “change” button. I guess the message is not clear, and you changed the page title to have a .php, which doesn’t actually do anything.

2 Likes

@duncan, I humbly hang my head in shame! Thank you! It works!!! I’ve been so stressed! :grimacing: