Email via web server not working (Hostgator)

Really dont know what’s going on here. I’ve set up the email form correctly. Spent an hour with Hostgator, they think something is wrong with the coding of the website.

Cant seem to get it working. Someone got any ideas?

@vfxwolf, @duncan will need more information to help but for now let’s see if I can help…

  • Do you have the “Thank You” page setup and have your form directing to it on a successful send? The Thank You page needs to be converted to a .php extension which Sparkle does on you confirming it.
  • Of course your hosting platform needs to support PHP but I’m sure they do.

I use Email Form Via Server and have never had any issues with it so I’m sure it is something easy!..

I think so @duncan

Here are some screenshots:

Seems alright. You’ll have to contact hostgator and ask about it.

@duncan, can you tell me what exactly I should ask them? The site is ready for release, but this is the one thing that’s holding us up.

“This page sends an email that’s never delivered, can you look into it?”

duncan, spoke to Hostgator…

Here are some screen grabs

I asked for the SMTP information…

I get this when I hit the send button the website

Looks like the problem is resolved. Thanks for the help, Duncan

Hi, do you know how it was resolved as I get this problem too. Thanks!

I’m still having the same issues on all of the sites we manage. This is spread across 3 different servers.

Sorry, @scoutdesign, thought I’d responded to this. Turns out I had set up a forwarding email on the server, not a conventional email. I didn’t want to deal with constantly logging in and emptying a mailbox, so after scouring the HostGator forums, I learned the solution was to set up a forwarding email mailbox, and not a regular one. Any email received at that address is automatically forwarded and not stored on the server. This doesn’t seem to work with Sparkle.

So while I was able to send email to the forwarding email, from say, Gmail, and it would respond, sending an email from the Sparkle mail form wasn’t working.

I went back in to my Hostgator cpanel, deleted the forwarding email, and created a conventional email with the same address, and it started working .

Hope that helps.

Thanks @vfxwolf for coming back to me. I am going to have a look tomorrow, but I’m not sure it makes sense yet!

With a standard email account against your domain name and it being forwarded the original email still remains in the account and a copy is forwarded onto the forwarding address, unless Hostgator does it completely different. So the email account will eventually fill up unless it has infinity storage.

A client asked me to do likewise and I had no issues with Sparkle working correctly and forwarding the email onto the forwarding address. So just to make sure you have to send the Sparkle email form to an “actual email account” address on your hosting server via cPanel and not to the forwarding address you have set up for the “actual email account”… that won’t work!

The key with any forms processing is to try and have your forms relayed to an email account within the domain. Many hosts are now paranoid about allowing their php sendmail function to be used to send responses to addresses outside of the domain. This is because some people, notably those who set up autoresponders, leave the host open to having their servers used as a spam gateway. If this happens, the domain owner will get a denial of service notice and will probably get black-listed. If you really must have your results routed to something like a gmail or hotmail address, you will probably have to use the SMTP protocol for mail delivery - something that can’t be done in sparkle itself, so you would need some form of script on your hosting server that you can point your form to

Almost all hosting packages will allow for the creation of a number of email addresses ending in the domain name, so the best option is to have one named something like web-contact @ your domain. You then have your form responses sent to that email address.

If you do that, there is absolutely no necessity to forward emails to third party addresses. Simply set up the account on your email client on your computer or phone (or maybe both). This way, all your emails will be delivered directly to you through the web-contact account. The only thing to note is if you intend to set up the email account on more than one device (maybe computer and phone) you should use the IMAP option when creating the account. This will ensure that all devices receive the email. If you only intend to use one device for email, you could set the account up as a pop3 account. this will enable the emails to be automatically deleted from your server once they have been received.

1 Like

Just to clarify… I was using a domain email address. In my case, However, I had set that up as a forwarding mailbox, so any mail it receives was forwarded on to my gmail address. It seems that was the problem.

Once I deleted that forwarding mailbox and set up a traditional mailbox with the same, the sparkle form worked.

Hello everyone

As an alternative to “Email ‍Form ‍via ‍Server”, there is an option to use a “Custom SMTP Server” to send the form, according to the Sparkle documentation:


Nice to see that implementation in sparkle - many other web development apps don’t provide this feature. I must admit I don’t use the forms function in sparkle, so missed the SMTP option completely. Anyway, its good that the option is there and using this option should definitely solve the problem of using external email targets in forms.