Follow Footer option - is it a bug?

I’v been building multiple test sites with Sparkle to learn what I can and cannot do with it. I am noticing a repeating issue, usually around a quarter of the way to completion of any site:

The elements I use to create a footer are a wide box, some text and social media buttons from imported .png files, grouped and set to Follow footer and Show On All Pages.

After some time, the page height ends up being hundreds of thousands of pixels high and I cannot reduce the length no matter what I do.

With the most recent bug, today, I decided to delete the Follow footer elements altogether and start again, but the problem dod not go away.

It makes me think there is an element placed somewhere out of site that is causing the pages to end up being 1000’s of thousands of pixels high.

I would really like to know how to prevent or solve this issue, as I have yet to build a site that does not end up with this problem.

@Chris, the only thing you didn’t mention was you didn’t go right to the bottom of the canvas where you can reduce or increase the height of the Sparkle canvas and adjust your footer(s) on the page to work in with the length of that particular page?

Pasting elements to one device size seems to cause the page height to change on another device size. If follow footer is used it seems to cause issues. Scrolling to the bottom of the page and moving the footer sometimes reveals an element that appears to have been beneath the footer. Rare though.

Thanks for your reply.

I found that there was a duplicate footer element on a page, 37500 pixels down. I don’t know how I came to make a duplicate of the original footer element on this particular page. This footer element, although not showing up on the other pages was affecting the page height of all other pages.

When I tried to reduce the height of the other pages, they would snap back to the height of 37,500 pixels (I’m rounding numbers here).

After removed all footer elements from all pages, the page height problem persists. It appears that there may still be an element on a page somewhere that is set to Follow Footer but I cannot find it.

Replying to my own post… :slight_smile:

My solution:

  1. Create a new blank page, call it ‘Master Page’
  2. Set the page to Exclude from Search and Exclude from Menus
  3. Exclude from Menus did not work, so I turned off that option, and turned off the page view in the Menu settings instead.
  4. Added some height to the page - about 4,000 pixels
  5. Added my footer elements to the page and set them to follow footer (and the main navigation menu at the top of the page)
  6. Set elements to Show on Show on All Pages
1 Like