"font not installed" even though it is

Hi all,

I see few questions on missing fonts but not quite matching my circumstances.

I was working on my sparkle file yesterday. I’ve published the site last year and just adding SEO data and making it more legible on smaller devices. Things were going fine for the most part.

My main font is Lato light which has installed early last year, no problems. No font issues yesterday. This morning I upgraded my MAC OS to big sur (11.1). My Sparkle version is 3.0.6 via the app store.

Opening up my sparkle file, I get Lato Light is not installed. When I open up a new file and add text, Lato light is available.

Should I re-install lato light? What would happen with the Lato light I already have installed? From the new test file I also typed with lato regular (also used in my current sparkle file) also works. But this was not mentioned in the error message when opening yesterday’s file.

Any advice would be appreciated.

Carey
NeotropicBirdProject

@NeotropicCarey, Are you using local machine fonts? or from the Sparkle font library, aka Google fonts?

I’m thinking, but others will chime in to correct me, that if you used a Lato-Light local font macOS could have done something funny with it via upgrade to Big Sur and now Sparkle is hunting for it. What happened when you asked Sparkle to “Install Now”?

Hi @greenskin,

I got Lato from a free font site. I think it was Dafont. It is also available on google fonts. When I clicked on the install now, a finder type window opened. I did not go any further as Sparkle had it available when I tried to create a new sparkle file. Also I had deleted the downloaded file once I had it installed.

btw I had installed Lato for use on pages, numbers etc. before sparkle and could with out any warning or error or request to install again after upgrading to big sur.

@NeotropicCarey, ok that makes sense then.
My take is that I always use the Sparkle font library unless I am using a specialty font so to prevent font issues down the track.

On your last point all what I can say is that Pages, Numbers, and Keynote are baked into the OS while Sparkle isn’t, but the great thing was that Sparkle acknowledged the issue in the first place! :slight_smile:

Hi @greenskin, thanks for feedback and advice. It is one of the options I am looking at.

1 Like

hi to anyone following this oddity.

to recap:

  1. published site last year. Using font called lato which as available free. Had installed it in Sparkle. All good!
  2. upgraded to sparkle 3.0.6. Merrily updating sparkle file with SEO Assist and making the site more readable on smaller devices. Not yet re-published.
  3. updated my mac os to Big Sur
  4. open my sparkle file and get a message that my LATO font is not installed. But I can see it listed in my font style… odd
  5. I downloaded lato from google fonts. After playing around with a test sparkle file and added text using lato, I open my in-progress sparkle file. And still get error msg that LATO font is not installed.
  6. so I clicked on “LATO-Light Preview not available” and the “replace with …” option bolds. (should have tried this from the start) I click it, and replace with “Lato” and error msg is gone. Looking at my content, the fonts looks good, even my custom name of the style is correct except there is an asterisk (asking if I want to update the style).I click on “apply changes”. and all good. The catch is I have to go through every page and every device to ensure all good. oh well… 2 steps forward, one back. This option is better than switching to a sparkle standard font which would have been more tedious and more work to get a similar look.

Not sure why my fonts were “not installed”. But for now, no road blocks and I’m moving ahead.

2 Likes

I have the same issue with a font that says it’s not installed over and over, and I click install, and it’s that every time I reopen the app. I’m on my phone and can’t remember which one, but it’s not a special font I installed, I’m sure it was on my MacBook before using sparkle.

1 Like

Looks like a font cache problem of some sorts, like the first Lato installment was named differently on the font catalog than the one within Google domain. I do recall Lato being added to Google Fonts really recently (2018 or so), so licensing and stuff are supposed to be different in the file.

Glad everyone is up and running now!

I am running into the same issue. I get prompted about font Hiragino Sans that I don’t recall ever using. I click on Do not install then Sparkle warns me that

Missing fonts will be replaced with a default font, the project appearence will be different from the original.

I click on the Lose custom fonts button and I can then start to use Sparkle.

I flushed the cache per @primo’s suggestion but that didn’t make a difference. This has been happening for many months, with version 2.8.x and every update since.

Here’s the thing: I made a copy of my Sparkle document as a “sandbox”, i.e. it’s where I get to experiment with new features before I go live with them. On the sandbox copy, I do not get the error message. I don’t recall if I made the copy using File → Duplicate from within Sparkle or if I did so in the Finder.

@Duncan, this issue is not a showstopper but it is annoying.

1 Like

Thanks yes we’re aware, looking.

1 Like