FTP assistance please

After 3+ hours online with my hosting service; this is their advice.
Kinda need some help here - cannot ftp from Sparkle to ONE of many sites.
One I really need it to work as it gets updated ALL the time.

From hosting service:
Then I am at a loss, as the ftp server is working fine because I connected no problem, and nothing is blocking you on the server as your IP is in the whitelist and you can upload to your other sites. Plus your ping test showed it is finding it on the correct IP.
All I can suggest is to contact the developers of the ftp program and ask them why their program is giving a ‘blocked’ error when it is a fully qualified domain name etc.

Kind Regards

Note I have tried secure FTP, FTP, ports 21 and 22 as well.

1 Like

Could I suggest @iVivid for you to assign a SSL Certificate against your domain…

Does this only happen for a single site or for all your sites?

Also does an FTP app like FileZilla or Cyberduck connect with the same settings?

By the way @FlaminFig, if this were a certificate warning during FTP setup it would not be about the web server certificate, it would be about the FTP server certificate, which is commonly broken.

Just this single site. And yes, Cyberduck works with the same settings.
Just uploading through that now. Can’t work out why Sparkle isn’t playing nice :woman_shrugging:

The other solution I could suggest is completely remove your site via FTP from your host, and have Sparkle publish it afresh.

Thanks @duncan for the clarification. I’ve never had a certificate warnings come up as I have all domains set up with SSL but thought to suggest it.

Try this instead:
Change the FTP Protocol Setting from Auto Detect to just plain FTP.
I bet this will solve your issue right away. It’s worked for me many times.

No; it didn’t. Had already tried that. I tried everything and after 3 hours of that posted here. Used Cyberduck in the end - same settings. Worked.

When I had this type of trouble the hosting company advised me to use SFTP protocol and gave me a specific port number (never heard of it before) that did work! I now use it on all my sites with no issues plus the ‘up to 10 connection setting’. Hosting is with WEBHOSTUK Ltd by the way.
Maybe worth a try checking with your hosting company for a similar solution?

One other quick solution that did work for me, as I was getting the error message too, I restarted my Mac and then tried it and it worked fine after that. Just another option to try. Hope you get it sorted as it can be frustrating

Hi, I found out that my FTP issue was due to the “Advanced Security” setting in my Comcast/Xfinity gateway (Modem/Router box).
Turned that off in their app, and my problem ended.
Before that, I was unable to FTP to my client’s webhost, FastComet.com. Very frustrating.
Don’t know if you are a Comcast/Xfinity customer, but if you are, try this solution in their App.
Worked for me! Good luck,

1 Like

I had a similar problem a while back – Cyberduck worked for uploads, but Sparkle didn’t any more. I discovered that deleting the publishing cache in Sparkle (which you can access in the pull-down menu: Sparkle - Preferences) fixed the problem. I had changed the password of my ftp account, but Sparkle still had the old one in the cache.


@atunnacl thanks for sharing. I can see how keeping the “Publish Cache” is important. That was a great tip, something Sparkle users should definitely make a note of. I had problems with the ftp. upload, but I just reverted to “Export to Disc” and used Transmit. I’m going to try to reestablish the ftp connection from within Sparkle after clearing the cache, for easier updating. Again, thanks for sharing.

– Paul G

1 Like