FTP Setup Problem(s)

I just upgraded to the Basic license and lost the ability to “Export to Disk”. (I didn’t see that one coming!)

I am therefore trying to get FTP set up to “Publish to the Web”. At my ISP, using their CPanel admin tool, I have a working FTP login, and a working website there at domain https://mysite.com. After reaching the Site Settings setup panel and detecting the folders at the site, I have tried everything I can think of to identify the correct folder location that the Site Settings tool will accept - I can only get the error message “The selected folder is not published to https://mysite.com”. Any experts out there willing to do a screen-share and trouble shoot this with me? I’ll pay for help. I have a Zoom license…

Thanks in Advance,

Hi @EdScott, I gave you a lengthy reply to this question via email, did you receive it?

No sir, I do not believe I did. Just went through my email including the Junk folder. Typically I get ±150 trash emails - perhaps I trashed it by accident? Please send again if you would be so kind.


Hi Duncan,

I looked again and yes I received it. I was confused about where it came from as I mistook it to a reply to an inquiry I sent to my ISP, MacHighway.com. I sent more than one request for help yesterday.

Your info is very helpful, but hasn’t resolved my problem yet. MacHighway offered to screenshare with me to help figure it out (tomorrow). I am down to suspecting a write error on the folder Sparkle is accessing when the Site Settings config tool tries to write a test file to it so it can then transfer it back to know the config is working. I did figure out more about the interaction of Sparkle with my site’s files. More on that when I respond back to your email to me.


Hello, I have the same problem using “Publish to the web” (version 4.5.9) and the same error. It would be nice if you could mention here how to solve this.


Hi @Hans, what problem? The “The selected folder is not published to…” message?

It’s even hard to search for in the community because it comes up in many flavors.

The two most common reasons are mentioned in our documentation about publishing:


A ‍couple ‍common ‍issues ‍that ‍will ‍prevent ‍this ‍from ‍working ‍entirely:

  • ‍‍if ‍the ‍FTP ‍user ‍can’t ‍access ‍the ‍folder ‍with ‍the ‍website ‍files, ‍because ‍it ‍has ‍a ‍restriction ‍to ‍access ‍a ‍folder ‍lower ‍in ‍the ‍filesystem ‍tree, ‍you ‍will ‍need ‍to ‍modify ‍or ‍recreate ‍the ‍FTP ‍account ‍on ‍the ‍web ‍host, ‍and ‍give ‍it ‍unrestricted ‍access ‍to ‍the ‍server ‍folder;
  • ‍‍if ‍you ‍are ‍setting ‍up ‍the ‍website ‍on ‍a ‍new ‍web ‍host, ‍but ‍the ‍domain ‍is ‍still ‍on ‍a ‍previous ‍web ‍host, ‍or ‍is ‍in ‍the ‍process ‍of ‍moving, ‍Sparkle ‍will ‍be ‍unable ‍to ‍access ‍the ‍“probe ‍file” ‍on ‍the ‍new ‍web ‍host, ‍you ‍will ‍need ‍to ‍wait ‍for ‍the ‍domain ‍transfer ‍to ‍complete.

This is most easily diagnosed with a screenshot of the screen where Sparkle shows that error message, as it contains the domain name you’re trying to setup publishing to, the contents of the server side folder and the location you picked. You’re welcome to post it here or email to feedback@sparkleapp.com and we’ll take a look.

Yes Duncan, it’s the “The selected folder is not published to…” message.
For now, the second issue could be the case, so I will wait ‍for ‍the ‍domain ‍transfer ‍to ‍complete. If that was not the solution, I will be back. Thanks for your answer.

Unfortunately I can’t tell you definitively what I changed to get it to work, and I was on the line with a support guy at MacHighway.com when it suddenly started working - seemingly with settings that had previously been tried in dozens of trial-and-error attempts.

For what it’s worth, here are the settings I am using that are now working now reliably:

  • Site Settings, Web Address: https://mydomain.com

  • Site Settings, Connection Settings: ftp.mydomain.com + FTP Username / Password + Connections = 1 _ Most compatible + Protocol = FTP with TLS

1 Like

Thanks EdScott. I will keep this in mind.

Domain is transferred and I did chose the settings EdScott said and now it works.
Thanks :+1:

Glad that worked, Hans!