Hiding a page from menu when viewing that page

Hi,
maybe I’m missing something obvious here - and maybe it has to do with the Auto Add Pages feature - which I do understand - but when I hide for example the ‘Home’ page by clicking the ‘hide’ eye icon for that menu item, that page disappears from the menu on other pages - in other words it appears to be a global setting, rather than a per page setting…?
So, is it possible to hide that page’s menu item while viewing that specific page?
If so, what are the settings I need to check/uncheck?
Thx,
Retroh
:slight_smile:

@Retroh, Maybe this is what you are after, just above “Alignment”…

Hi greenskin,
thanks for that speedy reply - but that option doesn’t appear in this circumstance (when I choose that page in the menu items list…)
Sure, I can ‘hide’ that menu item on that page when viewing it ON THAT PAGE, but it carries over to other pages - and vice versa, so that you end up going round in circles with no progress in the matter… It would seem obvious that you don’t want a page to appear in a menu when u r on that page - but this seems impossible in Sparkle at this time?
Please see screenshots attached…

@Retroh, You have Auto-add pages selected which has Sparkle do all the work. For now just untick it and while you have “Home” selected. That should allow you to “-” (aka delete) your home page link which will remove it from the menu across all you pages if you menu has been set up that way…

Hmmm - I’ll try that - but I suspect that it will remove that menu item from ALL pages - which is what I don’t want - I only want it removed from its own (home) page - where it’s redundant…
And that would be the case for all other pages where it looks a little silly to have a link (menu item) back to a page a viewer is already on…
:stuck_out_tongue:
My feeling is that there should be a ‘per-page’ option to hide menu items…

Uh-huh - tried your suggestion and as I expected, it’s hiding that menu item on all pages, so that approach won’t work…
I think this is an oversight on Sparkle’s part… pity.
:stuck_out_tongue:

@Retroh, The only way you could get around it is using “sections” which you already have. You can have a unique menu per section. So if you place your home page in its own section then you can remove the “Home” from the menu, but have “home” on all the other pages…

Wouldn’t that then compel me to create a section for each page?
I mean, the same situation happens on all pages - where the redundant menu item appears…
Or, am I still not ‘getting’ something obvious?
:stuck_out_tongue:

@Retroh, You would leave the menu as is with all your pages except for the home page which will now be in its own Section. The home page menu will need to be a copy and will need to be “Show on this page only”. Then you can remove the “Home” link without it affecting all the other pages.

Hi greenskin,
I think I must be a little ‘slow’ - coz the same situation occurs on all other pages too - where the menu item for that page appears - so how does this solve the issue for all these other pages too?

The solution would be to have one menu per page, set to add pages manually, and hide or remove the undesired menu link specific to each page.

The fastest way to would be to make one menu, copy and paste it to each page (not share the menu on all pages) then remove the undesired link for each page.

When adding or removing pages in the future you would repeat the process, or go into each page one by one and edit each menu.

Feasible on a site with few pages but if you have a large site that could mean more work later.

Hi Chris,
thanks for that solution and it makes sense, but my ste is about 20 pages - so just not feasible.
Having said that - maybe I’ll do it just this once…
:stuck_out_tongue:
Seems like an oversight on Sparkle’s part - to not offer an option to hide individual menu items on a page-by-page basis? That would obviously be much faster…
I wonder if there’s any reason that option isn’t available?
Maybe Duncan can respond?
Thx, Rohan

I haven’t noticed that feature to be all that common in navigation.

Maybe its there but I’ve just not noticed it.

Generally, navigation should be consistent throughout a website so viewers don’t have to think so much.

Otherwise its a hand code kind of deal.

But who wants to do that, EWWW! :stuck_out_tongue:

Hi Chris,
well this only happens when the mouse hovers over a menu - otherwise the issue isn’t apparent. But, who needs to navigate to the page they’re already on? Seems like an obvious statement I know - but there should be an option to hide the current page’s menu item when a user’s on that page…?
:stuck_out_tongue: