How to prevent menu from auto-adding pages?

I prepared the menu for the web site and I want it to remain as it is, without being changed.
Often I add pages (as I publish articles) and even if I unchecked the checkbox “auto-add pages” it does it anyway; this implies that on smartphone devices the menu moves to the middle of the page (due to the length of some titles) and I always have to put it back.
Every time I have to delete the article pages from the menu and this makes me waste more and more time…

It’s the checkbox in the menu settings, right under the list of items: “auto add…”.

Hello @duncan!
That checkbox is uncheck as you can see in the attached screenshot, but the pages are still added in the menu when I edit something in a random page. Anytime I have to select the page that I don’t want in the menu and click on “-” the minus botton to remove it from the list. However, the problem occurs again the next time I change something else in the project.
Moreover, for all the pages that I do not want as an item of the menu I clicked on “exclude from menu”.
I don’t understand where the problem is…

In the submenu from the screenshot attached I just need the first and the second items on the list.

The only thing I can think of is you are assuming unchecking the “auto add” checkbox will remove items already auto added. That’s not the case, you need to hide/remove items you don’t want manually.

Exactly, the “auto add” checkbox is unchecked from the beginning but when I add a new page clicking on the “plus” bottom left button, Sparkle continues to insert the new pages and all the previous ones created in the menu, which I don’t want it to do…

Never seen this, and it doesn’t reproduce in a blank new project. Please send your project file to and we’ll take a look.