Instagram not showing

EDIT SOLVED (support Sparkle is the best)
I can’t get Instagram to work, put a public adress in Post and nothing shows.
Facebook plug-in works fine. No Adblock , PHP 7.x

I have the same probleme… it’s OK for facebook and twitter, but not instagram !!!

It’s simple, I was doing it wrong:
"Ok so you set the instagram element to be of type “post”, but only entered a profile address: “”. This is not how it’s intended to work, and that’s why in the canvas you just see the placeholder.

You either enter a specific post such as or set the instagram type to “recent post” with index 0, to show the latest post.


I think I need some help here. Do you just add the instagram account name in the Sparkle Settings and then place the instagram box without the account name but with “latest post” ?

The integration of Instagram in Sparkle is quite simple, but it has a few important points to consider:

  • you need to connect your account via the Sparkle site settings
  • currently you need to have the exact web address you publish to, entered in the site settings
  • you can then either use the Instagram element to show a specific post or one of the latest posts you entered to the timeline
  • or you can show one of the latest posts in an image element
  • or you can show several recent timeline posts in a gallery element

Which you pick depends on what you are trying to achieve exactly. A common misunderstanding of the Instagram element user interface seems to be to place the instagram profile address when in post mode. That will not work, and Sparkle isn’t very communicative about this, you can only put the address of a post, the addresses look like

If all else fails please follow up with a link to the page where you have published your Sparkle site that contains non functional Instagram integration, and we’ll take a look.

Found what I did wrong. I had in my settings instead of - it works perfectly now. The https is the critical part. All I have to do now is to ask my wife to update her postings in Instagram. :smile:

Instagram seems to be a little tricky. Well I followed all instructions and tipps here in this thread, but my shwoing is not working. Actually locally it shows it, but on the web it does not appear. PHP should be all right with my provider, but I have no luck. Someone has a good idea for me? Would be nice!

Could you point to the page with the problem?
this would be the pages!

The problem is you have set your web address to, it should be just (general site settings).

Life is sometime so simple… thanks a lot Duncan. Have a nice eve. Eugene

1 Like

What a great design. And Instagram works :slight_smile:

Thanks Frank. Its nice to hear that… Eugene

Hello Community,

Today I updated Sparkle (3.1.1 (8500)) and suddenly Instagram post does not reflect on my homepage anymore.
I read here and tried as much as I can.
But I still could not make it.
This is homepage which I want to insert Instagram
If someone can help me to solve the problem, it would be nice.

Thank you very much.

I’ll suggest a couple of things…

  • You are not running a SSL Certificate to allow you to use the “https” protocol which Instagram uses
  • Check yourURL being used is the same in Settings / General / Website address
  • Are you running the latest latest update

Hi @Ken, unfortunately Instagram required a new authorization for Sparkle and their system for reviewing apps is completely broken. They did not authorize the request so far, but broke the working integration in the mean time. We are working with them to get Sparkle authorized under the new criteria again, nothing will change for Sparkle websites, but they’re not in hurry to fix it.

Thank you very much for your advice.

Thank you very much for your advice.
I understand the situation.
I hope, they will authorize Sparkle sooner.

I hope too, I had this problem earlier, in the meantime I only place the IG logo with a link.

Looks like Facebook finally authorized Sparkle again. Took them only a month!

1 Like