Instagram Site settings problem


i am setting up access to my instagram account.
In the settings tab, in the instagram part it asks me to authorize access to my account.
I set up my details and the icon of my profile appears correctly then it asks me to save my username and password and I do it. then it asks me to authorize access, I click on authorize but nothing happens.

am I doing something wrong?

Hi @igloo_f, that usually works fine. Is your account public?

I had this happen a while back and I realised I had to use “https” instead of “http” in front of my domain name in settings. But is your Instagram account set to public is an obvious one.

1 Like

thanks everyone, I’ve solved my problem about the access (I had connecting problems that day), but now I’ve a new one: my website is actually on but the instagram’s contents are not visible, there is shown only the gray tag but not my post.

could anyone helm me with this issues?

if you want to see it,

Ciao Francesco,

it looks like Sparkle has an invalid authorization from Instagram for your account. Could you try going to the Sparkle site settings, and in the Instagram section logging out and back in to Instagram?

Let me know.

1 Like

Hi Duncan,

first of all, thank you.

as you can see in the sparkle app I can see correctly all the posts but, after a new reconnect the instagram account in the app correctly. the effect doesn’t change. I’m trying to add a privacy policy. For you it is possible the problem is this?. because now I’ve the cookies banner but not yet the privacy policy page linked. I’m writing it and in one day I think I can public.

No the problem is specific to the Instagram authorization. Is your Instagram account public? I’m not sure about what other Instagram settings could affect it but it’s not something on sparkle’s end, and not the privacy settings.

yes is public Duncan, it’s a business page;

in the option there is the sparkle link active.

look the photos. before click the privacy button I can see the insta widget(but not the post), when I click the privacy button disappear the widget too.

We’ll have to look into this. Please get in touch via email:

1 Like