iOS 13.1 Frame Display issue

I’ve embedded my WordPress blog using a code block/iFrame, and it shows fine on desktop Safari and Chrome, but I can’t see it on Safari on my iPad (iPad Pro 2nd gen, iOS 13.1 beta). I’ve turned off all content blockers, but the embedded blog still shows up blank.

As of iPad OS 13, Safari requests the desktop version of a site by default, so this shouldn’t be a device view issue (I’ve only set desktop and portrait mobile responsive views).

Any suggestions? (Thanks in advance!)

Here’s the page in question:
https://hame.land/blog.html

…and the blog:
https://hame.land/hameblog/

It’s my personal site, so nobody but my mom will likely notice, but I’d like to fix it, and hope I’m just missing something simple.

Cheers!

https://hame.land/blog.html
Doesn’t show anything on iPad 12.4.1, just the menu

https://hame.land/hameblog/
Shows blog…

@hamishmacdonald, Ok I had a quick look through the code of the “page in question” and it has been blocked due to insecure content so nothing to do with iOS.

I see you have an SSL against your sub domain setup but it looks like it might be configured incorrectly or maybe a setting needs to be ticked to include sub-domains? Also if you can take a look and identify if you have any “http” in your page code (aka embedded code) because that is the problem.

The other way is to force all “http” to use “https”, but will take a small bit of code that you have to implement on your hosting server in the root folder (aka where your website resides).

EDIT : Your embedded iframe reads <iframe src='http://hame.land/htmly/' style='border:0' width=300></iframe> so your embedding a “http” iframe which your SSL Certificate on your domain name is saying no to.

1 Like

In updating the site the other day, I neglected to update the link in the mobile iframe, and sure enough that’s the page the iPad was displaying. (Despite the new feature of supposedly requesting the desktop version of pages.)

So I was able to update the link, but I also changed the URL in both versions to include “https”.

@lode.rosel & @greenskin – Thank you so much for your help!

1 Like