Leading zero in countdown missing in Sparkle 5.0.1

I have a countdown on a website that I regularly use, never a problem until now.

But with Sparkle 5 the leading zero in front of the days in gone.
When there were still 10 days (and over) to go, no problem, but with 9 days to go it shows just the 9 instead of 09 (while the example in Sparkle itself still shows 09).

This problem is seen in both the preview and the final version.

I guess this is a bug in Sparkle 5.


I can only check with V4.5.x.
Is the setting DD (1 digit) or dd (2 digits) for the date?

Mr. F.

The format is DD hh mm ss

It worked fine with the previous version, has gone wrong since I installed Sparkle 5.0.1, so I’m pretty sure this is a bug in Sparkle 5.

I can concur it is the case on Sparkle 5.
Best move it across to Duncan at feedback@sparkleapp.com

Thanks for the tip, just mailed the link to this thread to Duncan.


Maybe it’s by design?
This is a screenshot from 4.5.x

Same. On the canvas it is still 08 - but in preview it is 8 (single digit)

Mr. F.

I should read a post more carefully (and more often) before I write anything.

DD = one digit

The selection dd hh mm ss is missing.

Thanks Mr_Fozzie: I didn’t know that the DD generates the day without the zero.

Since the dd hh mm ss is clearly missing I guess it defaulted to the other option (of which the example is underneath is apparently wrong).

I found an old screenshot of a previous website, and I can confirm that the zero was indeed displayed…

This is not an evidence of a bug :smile:

You can recreate this with two smartfields countdown.

Even with version 5

Mr. F.

All what I will say is that it states “DD” representing double digits, there for if the days left are less then 10 then I would expect to see 09, 08, 07, etc…

One can argue about the syntax.

The fact is: the example in the settings is wrong and the countdown behaves differently on the canvas than in the preview (with this setting DD hh mm ss).

This would have to be changed.

Exactly, and I presume that this is a bug.

This is how I took care of it in the meantime, but I still presume that the disappearance of the other option is a bug.

After taking a look at the documentation, I agree with you: it’s a bug!

There you can clearly see “dd hh mm ss” as selection with the correct preview.

Mr. F.