Lottie animation not visible

Lottie Animation work fine in preview mode (during design). If I export the project to harddrive and call the page from the drive, everything appears to be working - but the Lottie-animation. It‘s not visible. The JSON file is present in the images subdirectory.
Btw, I tried with an own „creation“ and a Lottiefile, which I downloaded.
Any suggestions what I‘m doing wrong?

I must do something major wrong - or stupid :hot_face:
I tried an empty page - new project - empty and added a Lottie animation which I downloaded from Lottiefiles.com. Showing as designed in preview. If I export to local disc and call the index.html : no Lottie visible; but empty page :cold_face:
I don’t get it


It’s maybe this:

Most likely you are getting a CORS error.

For security reasons browsers don’t seem to allow you to load JSON files stored on your computer, it will work as long as the .json file is hosted online.

Try to upload it on a webserver.

Happy Holidays!
Mr. F.


Hello Mr. F.
Thanks for the hint. Exporting to a web server did indeed help!
Is there anything I can do to enable lottiefile playback by simply accessing the page on a local drive? Maybe adjusting some security settings?
If not - too bad, but well.
It’s good to know that there are some pitfalls like this that a normal user (like me) would never come across on their own :hot_face:
Happy Holidays!


I have no answer for you. I found the security issue on Google. Maybe you can try different browsers and disable all security settings just for testing this. For some reason the developers of browsers have implemented this.

Mr. F.

I’m afraid the way the lottie player loads the source lottie file is not compatible with offline mode. We should clarify this in the documentation or parts of during the export process.

Thanks Duncan. Yes I think it would be worth noting in the documentation.
Best regards

Would be amazing to have Lotties frames synced with scroll, so when someone scrolls Lottie plays at the same speed :))