Password Protection - page not showing up

I have to throw in the towel on this one and ask for help.

Building a super simple two page site for a 16 member home association.

I have all 16 member user accounts set-up in the Settings > Password Protection area. Each member will use email to login, and their home address as a password.

I have the Login page directed to go to the second page in the site, which is set as password protected. Everything is uploaded. The login page seems to work, but the redirection does not.

Any thoughts? I don’t know how it could get much simpler.

You can see / test with a valid user login and password from this screen shot.

Thank you, Craig

I’ll add this image from FTP, in case it helps.

Hello :wave:t2:

Does your hosting plan support PHP? If so, make sure that the PHP version is at least 7.xx or higher.

Good idea. I am pretty sure it is setup and ready, but I will check. Thanks. C

Are you using an IIS hosting server which is all about Microsoft and not about the world wide web?

I have looked at my Cpanel and spoken with tech support. The default PHP running on the server is 8.1. The tech person lowered the PHP to 7.2 and the login page worked instantly. Their conclusion is that Sparkle is exporting PHP files that are not compatible with 8.1.

I can find nothing in the preferences or site settings which allows the user to select the PHP version upon export, though the documentation says “at least 7”. Is there a way to know exactly which version is being used? I think it would be best to know what Sparkle is doing, then match that on the server.

Here are the choices. Thanks Craig

That’s surprising because my server is also set to version 8.1 and I haven’t encountered any problems on my side

Huh, that’s really surprising. I would think they have a slightly different configuration between the two. We have many many customers using all versions of PHP…

One problem / resolution I stumbled upon with the User Accounts. I was copy and pasting the email addresses from a couple different sources, and one of my test users just could not log in.

The UserName is an email address, but it also included 4 or 5 blank spaces after the .com, like .com______ (empty invisible spaces). I just happened to notice that my cursor did not line up after the M. Once I deleted those spaces, that person was able to sign in.

Maybe that will help someone else.

Ah thanks, that’s definitely an annoyance we should fix.

1 Like