Popups - form fields and mobile

Hi all,

Thought I would try utilize a popup for a “sign up form” on a site I’m working on.

Well, I’m having 2 issues:

  1. Can’t seem to get the form fields to show on top of the popup. Tried changing layering, grouping all the pieces in the popup together; but in preview, the popup comes up, but the fields are behind it, and not incorporated (or moving with) the popup.

FYI, 2 buttons I have on the popup work just fine.

  1. I do know popups are not really for a mobile device (maybe a mega menu), but I can’t seem to hide the popup on the mobile version of the same site.

I likely missed something, but if you can help, thanks!

@TomJr, Ok lets see if I can help…

  1. This is strange! Maybe delete the popup and start over. If you did delete the form popup and the form elements remain then that would show they are not on the popup layer. Naturally a popup will group all the elements you place on it automatically.

  2. Yes on mobile the popup is tricky so I would keep the following in mind…

  • make sure the close button remains at the top right of the popup
  • leave room below the popup so Users can tap outside the popup to close it
  • make sure you have selected (popup settings) Click Outside / ESC To Close which will allow a couple more options in exiting the popup
1 Like

@greenskin, thank you for your reply!

Perhaps deleting the popup and starting over is a good idea. What you said is correct…I had the form fields already on the page, and decided to copy/paste them into the popup. Might not be the way to do it.

I honestly didn’t think a popup would work on mobile, so I’ll take your hints on them. Thanks!

Hi @TomJr, sorry about the trouble, this sort of misbehavior is not something we expect, if you still have the project file please send it our way (feedback@sparkleapp.com).

@Duncan, not a problem. I ended up deleting the popup and starting over. If it continues, I’ll reach out. Thanks!

@greenskin, @Duncan,

I just recreated the popup, seems to be working. However, I’m not seeing a setting for a faint gray background showing up behind the popup. How do I get rid of that?

In the canvas? That’s just to clearly separate the popup content from the canvas behind it. Doesn’t show up in preview. This is for normal and fixed popups. Modal popups have an actual background.

1 Like