Problem with displaying Google Maps


I am facing problem with displaying Google Map on the contact page of my website. I have generated the API Key already and have also enabled the Maps Javascript on that API. I have also restricted the API Key to open only through the request sent by the domain Punjabi Nukkad - Delicious food cooked with love and passion, still I get a black placeholder.

Has anyone implemented the Maps feature in their website and can help me resolve this issue !!

Screenshot attached below.


Google wants billing enabled in the account. Maybe that’s the problem. To tell for sure you can share a link to the page so that the output in the javascript console can be examined.

No, haven’t had this issue with Google Maps.

Checking the development code via the browser you have been given a 403 error, so there must be a setting or a needed validation to prove yourself with Google. As Duncan mentioned the Basic Map with API needs billing enabled.

Now that Google has the power it is certainly wielding it!!! :frowning: :poop:

Hi Duncan,

I have provided my billing account information already and it allowed me to download the API Key only after that. Link to the page is as below:


I can only think of a mistake in setting up the restriction per domain, try removing that.

Hi Duncan,
I removed all the restrictions and made sure that Javascript API is enabled for the API key. Still the live site does not show the maps. The billing account is also active.

Then I copied the iframe code from the browser into notepad and changed the “disabledsrc” parameter to “src” and it now shows the map in Preview…

I don’t know what this means, but changing one parameter in the code made it work.

All screenshots are attached below.

		<iframe src=",%20Bacchus%20Marsh,%20VIC,%20Australia&zoom=13" style="width:100% height:1200px border:0" loading="lazy" allowfullscreen>

Map Displayed


Actually it seems to be working correctly now. The code is correct in consideration of the privacy support.

It’s only showing the Map within Sparkle ( I guess after removing the restrictions), but still does not show anything in the preview or on the live site ( please check the live site Punjabi Nukkad - Contact Us )

I don’t know whether I am doing something wrong or if this is a bug. If you want, I am sending you my Sparkle project file to have a look.

Sparkle project file


What can I say. After accepting the cookies, the map is visible.

I have not tried all devices, but it works on the big MAC.

Awesome, it’s working now. I had not clicked the accept button. Thanks @Mr_Fozzie

It’s actually working now Duncan. I hadn’t accepted the cookie warning. Thank you for all the support…