Publish options not available

I’m using 2.8.10.

Just updated. Site wanted to upload every file instead of changes. Went to set up and wasn’t given the option of Fast or Safe.

Do I need to delete the setting and start over? It was obviously there before.


@busterv, Welcome onboard! :slight_smile:

It probably would be best if you ran this past @duncan for more accurate feedback. The only thing I can say is when I re-published one of my existing sites with the latest iteration of Sparkle (V2.8.10) I noticed it doing the whole site so it could be a “standard” after a new iteration is released?

Should I email him or does he check this regularly?

It might even be worse. Generally I put the site on my computer and use Transmit to transfer and am getting error messages that say it can’t be uploaded becuase they are “read only file system”

Attempts to upload directly from Sparkle to the site also have failed. But I’m trying this method again now.

Yea. Failed again. It doesn’t seem to be a connection issue but there is some problem with the files it seems.

Never mind, contacted web hosting compay and they solved it. Not sure what the upload problem was but it’s solved.

Still would like the option for a quit upload or a complete one though.

@busterv, Sorry for the late response… busy with clients. Yes if you have a weird issue you can contact Duncan on I also included Duncan’s handle when I responded to you earlier so Duncan would come across it.

Really happy you found a solution!
Did your hosting company mentioned what they did? I remember Duncan talking about something like this a while back…

Sparkle will always publish only changes if it can. The option was removed because it was giving a wrong impression of how it worked.