Publishing output has no "index.html"

In the Settings > Publish Local Business information on page; was mostly blank.

But the main was the exclude from publishing” checkbox was CHECKED.

Wow, I somehow after a year of updating this site I really messed up and check marked it.

Thank you Duncan for the obvious mistake on my part.

It really does exclude from publishing.

This came at the most difficult time I’ve had in a long time. I had just uploaded another web site into my main hosting file. AHHHHH. Had to clear everything 2 of 5 sites in the folder. That was a mess, at least for me. Both sites were community service sites, not commercial sales.

I really was hard for me to understand I can publish other sites I built, but not this particular one. Just would not publish. Brain fried completely after midnight move to another computer (macbook air) and install Sparkle and publish did not work again, even with older files & older Sparkle. AHHHH.

Thank you Duncan for the clear head and responsible and obvious reply.

Hi @golden1one, that generally happens if you don’t have a home page set in the project, or if the home page has the “exclude from publishing” checkbox set. If it’s neither of these, I’ll have to take a look at the project file.