Publishing stuck on image

On and off over the past 2 weeks I’ve been trying to publish my site but sometime during this process the upload gets stuck uploading a different image each time (Uploading ‘images/randomphoto.png’ (100%)). The progress bar for the upload never gets past ~1/7 complete when this issue occurs too. I’m trying to upload 4.2GB of png images ~80 images total, many of which I can see from cpanel file manager have been uploaded successfully. I have my computer set to not go to sleep while the upload is in progress and have been letting it upload undisturbed overnight most times with no success. I have also trying playing around with the publish ftp connection settings with the help of tech support from my web host (bluehost) however nothing I have tried has worked yet. I’m seeking some advice on what I might change in my process to complete a succesfull upload becuase at the moment I am stuck :raised_hands:. I thought maybe that the connection might be timing out due to using Nord VPN but I have since been closing out of my vpn while making upload attempts but this did not make a difference.

Publishing images can be slow, particularly if you have several of:

  • many images
  • a project with many devices and 1x/2x/3x images enabled
  • the “better compression” image setting
  • a slow Mac
  • a slow connection

Also images are reuploaded and in some cases recompressed when you delete the publish settings, so I suggest trying again by dialing down all the settings and giving it time.

1 Like

I have seemed to fix the issue and now publish times are relatively quick. I checked my image settings and they were set to

  • 1x/2x/3x
  • faster publishing

I left these as they were because previously switching pixel densities set to 1x on mobile galleries look blurry.
What I ended up doing for now was turning off generate webp images and bulk converting all my .png images to webp via the cwebp terminal command. I then relinked all of these webp images in place of the png images and now I can publish again.
I realized after doing this that sparkle is recognizing these webp files as jpegs, but with some of the pngs originally being 200+MB and now after converting to webp being in the tens of MB I think the issue was getting stuck compressing some of these large image files.
My question now is, is the convert to webp image setting the only way to upload webp images using sparkle since the insert image tool only shows jpeg,png,gif, & svg?
It seems kind of round about to export images to png, convert to webp, then sparkle reads them as jpg. I;m going to do some testing with exporting lower quality jpegs but I suspect the quality will be unusable to try and get them down to the size of the webp files.

Pre-converting images isn’t really useful, as Sparkle will always re-encode the image for the devices and pixels densities it needs. Sparkle does read the image as webp and showing “jpeg” in the user interface is a little confusing, let’s say it’s more like saying “it’s an image without transparency”, and jpeg is the default output format for that (as opposed to “png” for images with transparency).

Sparkle will generate webp images on its own (and the supporting code) if you check the checkbox in the images settings. I suggest only using 1x and 2x pixel densities, 3x is generally unnecessary.