Questions on internal links and caches


  1. Is there a way to control whether or not internal links contain www in the url?

For instance my internal links are starting as
Is there a way so all internal links start as as to avoid redirects from the version without the www? I have my htaccess file set up to auto redirect automatically, but was curious if there was a way to avoid the need for the redirecting?

  1. Is there a way to use cache headers for images, javascript, and css to help speed up the serving of webpages for users that regularly visit the site?


  1. set the web address in the site settings
  2. Prevent browser from creating a cache of page - #3 by duncan

I may have experienced a unique bug. When I created the website I had originally had it as in the settings, however I had changed it soon afterwards to include www. I hadn’t noticed until last week when I looked at the source code that the internal links were still not using www and were causing redirects which I had previously already took care of in general with code in httaccess. I went into Sparkle, deleted the www prefixed web address in settings, saved the file, and then reentered the address again as and it started exporting with the proper link form. Perhaps a one off glitch? Anywho, this program and leaps and bounds above my last website creation program… iWeb. I milked that until I couldn’t do so anymore. I had a partition on my hard drive with an old OS and used it throughout that until coming across Sparkle. Thanks for the help with the cache! I was having trouble with my website rendering properly in some instances after updating the website where the layout was all out of whack. Killing the cache prevents that from happening.

@EricExtreme, It sounds like you have cPanel access…

If that is the case go to the Domain Redirect settings and ask your domain to redirect all www and http to https. This is a permanent setting unless deleted and will overcome all https issues.

No need for a modified httaccess file.