Real Estate template - am I doing something wrong?

I’m using the Sparkle real estate template. It won’t load the pages when I upload it to the server (I’ve done a few edits to make it more like New Zealand)… I notice it doesn’t have the home page as index.html instead it has index.php; can my server (just normal cPanel) not read this. I’m no expert by any means so if I sound dumb please forgive me. All it gives is like a site index when I try to access the site its at.

I have tried deleting the entire site from cPanel, and re-uploading it. Same problem.

What does “won’t load the pages” mean specifically?

@iVivid I don’t think the folders I see in the picture belong to Sparkle?

Also I highly recommend using the built-in publish to the web option. It’s a lot more convenient.
But if you’d like to export to disk try to select “High Performance” if you selected Offline compatible?

I think you should also disable indexing to have more security on your server.

https://www.interserver.net/tips/kb/disable-directory-listing-cpanel/ or contact your hosting provider, they will be able to help you disabling if that’s an option for them.

1 Like

Duncan, the picture I posted is what shows on my computer when I type in the url. When I try on the phone to load the url I get this picture.

Hi Matt; that picture is what shows when I try to load the url on my mac. I did use the built in publish option. The files are all there when I log in to my server, I think the issue is it being index.php instead of index.html; however I do not have enough knowledge on how to deal with this.

@iVivid, it will depend on how you have set up your subfolder called “realestate”?

Is it a sub domain you have created? or have you just created a folder in the root (not public_html)?
I see your Ivivid.co.nz is working fine so it is how you have setup “realestate” and then have you matched that up with where Sparkle is Publishing too…

On a side note the sever system prioritises .html and that is the first page it will offer up. If you have a php page then that needs to be specified if a html index page is present. If there is no index.html page present then the server will automatically server up the index.php page.

1 Like

Yes, I created it; I use subdomains all the time and I did it the same way. There is no index.html file. The subdomain is showing in cPanel under my list of actual subdomains (so it’s not just a folder), and the files appear to be showing in the subdomain folder - they’re the same structure as my other subdomains apart from it being index.php not index.html. No idea what else to try.


Well something is not correct?..

Your latest screenshot definitely are Sparkle uploaded files. So I have hunted the following link - https://realestate.ivivid.co.nz/index.php and I get a 404 error, Not Found - The resource requested could not be found on this server!

Just a question, do you have other Sparkle websites running on a subdomain?

This appears to be a hosting setup issue. Maybe you don’t have PHP enabled on your hosting plan or on that subdomain? The index.html file can become a php when you have some features on that page, say a contact form, or password protection, or some smart fields.

Yes, I have about 10 sub domains live. Such as www.labels.ivivid.co.nz; https://www.confectionaryphotography.ivivid.co.nz/

I have contact forms on all my sites, so it can’t be that. I can see php files on my other sites, but none of them have a home page of index.php… since this is a template from Sparkle is this real estate template different in some way maybe?

Perhaps the home page has accidentally been set to have password protection?

No, the “Protect with Password” is not checked. All I did was open the template from the Sparkle templates, replace some text and pictures and delete some bits and publish. Fixed now as per my final comment. Thank you!

OK I HAVE AN UPDATE. I got this from my server company.
Hi Viv,

There was an issue with the subdomain config files in the web server. This has now been corrected. Please allow a hour or so for caching to clear.

THE SITE LOADS PERFECTLY NOW!!! :grinning: What a rigmarole - and I thought it was me!
Thank you so much to everyone who tried to assist me with this. Much appreciated indeed!

1 Like