Scroll bar is painted with page's BG color

This is a minor but strange issue.

The problem is the vertical scroll bar is painted with the solid background color of the page.

I can reproduce the issue with the following conditions.

  • Safari 2.1.1 on macOS 10.14.5 (No issue with Chrome 75.0.3770.100)
  • Both web server and live preview
  • On a particular page (and the localized version which is almost the same) on my site

I suppose this might be a bug of Safari but also suspect my Sparkle file is partially corrupted.

1 Like

Corruption of the Sparkle file would result in the file not loading in Sparkle. This is something about the code Sparkle produces, but I’m not sure about the exact issue. Can you show a screenshot? Some place online where to see the issue? if you prefer.

Hi Duncan,

Thank you for your quick reply.

I’ve sent the information to

Should this come up for anybody else, the page background color bleeds through in the scrollbar, even if you have covered the rest of the background with full-width boxes.

I think the behavior depends on the background color.

Here are the steps to reproduce.

  1. Create a new sparkle file.
  2. Enable live preview.
  3. Create a new page. The default background color is white.
  4. Add a text box and locate it at the bottom of the page to enable vertical scroll.
    5 Change the background color to black.

I don’t know it’s the same issue, but when I changed the background color on 1 page with the color picker, all the other pages changed to this color.

Hi @lode.rosel,

It seems to be an expected behavior.

Could you check the description below on

  • When ‍the ‍color ‍value ‍of ‍a ‍swatch ‍is ‍changed, ‍all ‍elements ‍using ‍the ‍color ‍in ‍all ‍pages ‍will ‍change.

Hi @duncan,

The main point for me is why the behavior is seen only on a particular page.

My understanding is as follows:

  • The behavior is caused by the implementation of Safari.
  • The behavior depends on the background color property of the page.

I will leave it unchanged.

@c3pop Yep, you’re right, I overlooked this… My bad.