[Solved] Preview and Publish different for Countdown [Sparkle update] and Wrap Text [Browser issue]


I’m seeing some oddities showing up recently and wonder if others have seen this. Both are differences between Preview and publication.

    Using countdown to report the days until an event, Preview shows properly as days (14, see Image A) but when published it seemingly shows the year (2022, see Image B). Link to live page here. The images come from Safari but also occurs on Brave.

Perhaps this is a server issue? Site runs on Linux server with CentOS.

Image A

Image B

    I recently noticed another difference between Preview (see Image Contour-Preview) and live page (see Image Contour-Live) when using Wrap Text around bulleted lists. These images are from a desktop using Safari but also observed on small screens–iPhone (both) and Android (Live only). I increased the margin (from 5 to 8px) but observed no/little improvement. In fact, the live page is 8px while the images have 5px. Link to live page here.

Maybe an interaction between margins and wrapping commands?

Image Contour-Preview

Image Contour-Live

Thanks for any suggestions.

The first seems like a problem with a misconfigured server. What’s the date on the server?

The second is a problem with text wrapping vs. bullet lists, in fact I’m not sure why it works in preview. Essentially browsers ignore bullet lists in the wrap shape and let them hang inside.

Thanks Duncan.

  1. The date seems accurate enough. Here is the date/time stamp for the folder/file of interest (taken from cPanel File Manager):

  2. Cool. Good to know. I’ll move image to the other side of the list. Maybe that’ll work.

Also, I noticed another difference that makes me re-think my server hunch: Looking more closely, the “13” includes the flipboard framing (on Preview) while the “2022” does not (Live page).

@duncan Would this suggest more than a server effect?


In your case it’s not the Flipboard framing. I have tested it in my “secret area”.

But there’s a bug in it anyway: when i switch back from flipboard to no effect, the text style is not reset to what it was. The gray shaded background remains. That needs to be fixed.

I do not know much how a webserver has to be configured. But what happens when you set the countdown to show yy instead of dd? Or any other date structure?

Mr. F.

I just tested preview and published site and it works fine.

What are the full settings of your countdown?

What PHP version is your server running? Maybe it’s something in that area.

Thanks @Mr_Fozzie and @duncan for the effort and comments. :bowing_man:

Let me play with it a bit and will report back after.

Conclusion: Inconclusive, not a simple answer but probably a server-specific issue (revised, see below).

@duncan: The PHP version is 7.4.30. I will send full server information via email. Perhaps that will show something.

After some testing, it seemed the Flipboard has an effect, as @Mr_Fozzie suggested. Turned off the Flipboard and two identical countdowns on the same page appear different, as demonstrated: “2022” is with Flipboard effect, “13” is without it.

Unfortunately, it is not this simple of an answer. Flipboard is likely an effect not a cause. Even without it, the problem remains but in an altered form: toggling between two numbers–DD and YYYY (it seems). Link below to a live example. Hit reload if it doesn’t begin immediately.

(fixed) PPecard.net
(error) [BUG] rlmc
(fixed) [FIX] rlmc

After much additional testing, I was unable to eliminate the problem, even deleting all Smart Field options, re-adding without Flipboard, even tested on a new page, re-uploaded the site on a fresh testing site, deleted specific files on the server, among a few others. And, yes, I deleted cache and tried different browsers.

Conclusion: [see next post] (not a server issue)

Rather than continue trying to solve this irritant, I changed strategy. No need to display the specific day; will just say “soon.” The effects of the countdown work well–close a popup and redirect to a different page (with Smart Field display off). These are very nice features, with ample thanks due to Duncan and all.

Pressing on… Thanks for any other suggestions you might have.

After multiple specific tests, was determined to be a program problem not a server issue.

Revised Conclusion: Was not a server issue. Sparkle App update solved the problem.

Another efficient solution by Duncan et al. :clap: :clap: :clap:
Thanks much!