Videos are not played back on QNAP Webserver

I inserted a video (mp4) on a page - which will play back o.k. in preview however, if I publish the site to a QNAP NAS (I got 2 different NAS and it’s the same with both), everything works fine - but the video. Instead of playing the video I see the initial picture and the controls (if they were selected) and nothing else happens. I cannot get the video to start.
This even happens with the Sparklecafe “Underwater” Design. The background video (water.mp4) is not playing.
If I export the website to my internet service provider - it works fine. So I thought it’s an issue with QNAP (and yes I know about the multimedia license issues with QNAP - and they are not the issue).
However, I prepared a homepage with a different web design app (Xway beta), used the same water.mp4 file and it does work on the QNAP NAS as expected.
So there must be an issue in between Sparkle and QNAP ?!?
Did this occur to anybody else? Is there a hint, what I could do different?

This really depends on what the setup is. Are there any warnings or errors in the javascript console?

Sorry no, Duncan. Would it make sense to send you the index.php file? Because that’s a preset - though editable. But I am not familiar with this. I even don’t know whether it got anything to do with this problem.

If once published to a web host the site works fine, clearly the issue is with your local setup. That needs to be debugged, I’m afraid I don’t know how to help.

That said it is surprising that no error is logged in the browser javascript console.

I once got an error message that the file would not be found. But I cannot recall under which circumstances this occured because lately I don‘t get any message - just a frozen pic.
Could this have anything tomdo with the index.php?

Sorry that’s an exceedingly vague question. I don’t think the page coding is incorrect.

I don’t have exactly the same problem, but I just wanted to mention that the background video “water.mp4” which is supposed to be stored in the file and shows in Sparkle, is not visible (and of course doesn’t play) in Preview.
And the Poster Image is not changeable/working …
As I don’t use the Underw.Sparkle file - just wanted to learn stuff - I didn’t upload it to the server.

Just tested and it works fine for me. What browser are you using? Does the browser javascript console show any message?

Thanks for testing, @Duncan. I tried it in Firefox, as I usually do, and all my videos work. My browser console didn’t show anything.
BUT: After your lines I opened it in Safari - and it worked. Sorry about the fuss, but I still don’t know, how I could check in Firefox what’s wrong other than in the browser console. And I don’t know, why all my mp4 videos play in Firefox, but not this one.

I tried Firefox and it also worked, so I’m not really sure. Is it an up to date version?

It tells me “firefox is up to date”. Could it be that I - some time ago - turned java off in firefox? Is Java necessary to play mp4 videos?
Sorry for not knowing basic things …

Edit: I checked and realized that I don’t have Java installed on Firefox. When is it absolutely necessary?
Edit 2: I just saw that the water.mp4 just plays once when I first open it in Firefox, but doesn’t loop, just disappears.

Well the point is that all necessary files are present, the page shows absolutely correct, if I open it by double clicking the index.html on the NAS (mounted volume) or in preview mode from Sparkle. However, the video doesn’t play, if I open the web page by calling the url. You may try yourself by calling
I don’t have the water.mp4 as background video, but I linked it on the top right videos. I tried with different browsers.
I suspected a problem with QNAP and opened a ticket there, but they seem not to understand my problem or are not trying too hard to help :frowning:
But again. If I code a page with Xway and store it on the NAS - everything works - including video.
I have no clue what to do …

On the iPad I get this error message
You don’t have permission to access this resource“

I think I found the bug with the QNAP NAS. One cannot use a folder called “Video” on the web server. Files in the “video” folder cannot be accessed. Xway uses a folder called “ressources” to store media files. When I renamed this to video and also changed the index.html accordingly, I get the same result as with SPARKLE. On the other hand I renamed this folder to “test” and adjusted index.html again - and it worked.
I will get in touch with QNAP on this issue.
But: is there a chance in SPARKLE to use a different folder name for “videos” - as it appears to be treated with different user rights on the web server!

Hello @Tomki

Yes you can rename the “output folders” if you purchase the “Developer Tools” in Sparkle site settings …

You made my day @Shadowfax! Thank you! It work’s with a renamed video folder.
That proves however, that QNAP has an issue which they obviously can’t resolve otherwise.

1 Like