Website loading problems and problems with scroll locations

I am renewing my website and I have decided to move from Mobirise to Sparkle.
The website is and it is still under construction. Being my first complex experience with Sparkle I have uploaded it to the hosting to check the progress.

Everything went well until yesterday afternoon, after the penultimate publication, I find that the web does not load well neither the video, hosted on my hosting, nor the images and even the entire page.

Video with problems

At first I thought it was because of my Internet connection that is not too powerful, but today I still have the same problem although I have been in a live online course, without major problems. This makes me think that it may be something related to the web publishing rather than the Internet bandwidth.

I should say that all the animations on the home page are made with Sparkle, i.e. no external code.

Maybe I’m making one or more mistakes, like publishing very often directly to the hosting (it’s something I’ve thought about) and that’s why I’m asking.

Thanks for the answers.

Your site shows normally now. The site shown in the video seems to have had issues with an incorrect publish or an incorrect server cache, very hard to say just looking at that.

1 Like

Thank you very much for your reply. On my computer it is still giving display problems. I have thought to clean the hosting and republish again, because if any error has been generated.
It can be a good idea, right?

But as I said the site shows normally. There was no problem publishing, just a problem with how it’s delivered to your browser.

I would suggest clearing your browser cache, and if that doesn’t work then it might be a server side cache. To fix that you would need to contact your web host and ask them to clear or turn off the server cache.

1 Like

Ok. Thank you Duncan, it is much clearer to me.

Very nice site you’ve created! Love the colors and the design!
No problem with it loading quickly on my iPhone!

1 Like

Thank you very much for your comment.
I’m glad you like the website. :smiley:

I still have a lot of work to do to finish it and I’m reassured that it works well even on iPhone, although the mobile version is not yet ready. I’m also working on the German and English version. :sweat_smile:

I’ll show it in the corresponding thread when it’s finished. :wink:

Fascinating start page. Very nice!

1 Like

Thank you very much for the feedback, Adrian. :blush:
I hope to finish it in the next 15 days. :pray:

I am reopening the thread with a new question to keep everything together. This time I’m having problems with the links to the “scroll locations”.

Let me explain. Each page has two menus, one for the page itself or another for the whole site.

The one for each page is navigated through the scroll locations and it works fine. The problem comes when I want to navigate from the general menu of the web to a specific scroll location of another page or of the same page.

When it is from the same page it can “hit” the first link but if I repeat it doesn’t work, it goes past the “scroll locations” anchor point or it doesn’t reach it.

On the other hand, when it is from another page, the link works fine, but it gets stuck in the scroll locations and does not allow you to browse the page normally. I have to go to the browser URL and delete the name of the scroll locations to be able to navigate the page normally.

I thought it only happened in the mobile version but it also happens in the desktop version.

Do you know about this problem?

It’s the same website as in the first post

I’ll just add @Saeta that I have not seen what you have posted?
I have tried in two different browsers and all looks correct with your anchor points.

What browser are you using? And is it updated to its latest version?

Thank you Flaming.

I’m working with the latest version of Sparkle and I’ve encountered the error with Safari on iMac and iPad and Chrome on Xiaomi on several occasions.

If it doesn’t replicate the bug with your computer, maybe it’s because of my internet connection (it’s not very good here in the mountains). That’s the only explanation I can find.

I’m going to try it again on other browsers and computers to see if the error is replicated.

Ruling out that it’s a bug in my use of Sparkle is already a good step. :wink:

1 Like

Well, I think it’s because of my connection but I have doubts.

I have checked in Chrome, Brave, Safari and Firefox. In all of them the error occurs while the page is loading. Once it has loaded completely everything flows fine.

I have also seen that the Url generated by using a link to an anchor point from a different page looks like this for example: Portfolio

And the anchor point #illustration does not change even if you click on another item in the general menu or on the page itself.

However, when I navigate from the menu of the page itself, the anchor points do not appear in the Url. Is it possible to clean the previous Url somehow?

I don’t know if this could be a reason for this failure.

I have also tried using mobile data with my Xiaomi to check the network issue. Here I have no other options than Chrome and Opera.
It goes more smoothly but does not respect the anchors if I use the general menu (+) it really links roughly and if I click more than once on the menu item, it keeps scrolling but without reaching the anchor point.

It seems a bit strange behaviour to me.

Sorry for the blind questions but I have no other way to check if it is because of me or if there is a bug.

I suggest separating in a different thread in the future, this become a mix of topics that’s hard to search/find and to figure out.

I honestly have not understood what the problem is.

I apologise Duncan, I really thought it was better to post here than to open a new thread. I take note and will follow your guidelines next time.

As I think it’s a performance issue, the best way to show it is on video.


I have waited more than half an hour for everything to load in cache and see to what extent the problem was replicated. At the beginning of the video I show that all the content is loaded and working and that all the anchor points work perfectly with the header menu on the Home page.

I explain the structure of the website.

The pages that have more content have a menu at the top so that you can navigate within that page.

After that, there is a general menu in the + icon at the top right. In it is the navigation through the pages of the site, and also to the existing anchor points on the long pages, as a submenu.

Well, the problem is happening mainly on the Home page. When I try to go from another page to a section of the Home page, for example #reconexion, the navigation inside the page is blocked.

The same thing happens if you type the url with the address to the anchor point:

I checked the time it takes to return to normal browsing: 1’57".

The fact that it unlocks after almost two minutes makes me think that it could be a loading problem.

As I said before, I am aware that my internet connection is not very good, but I can watch videos normally. Some days they take longer to load than others, but I can watch them.

Something that has caught my attention is the Url generated by an anchor in the Home page when landing from another page: Home
However on the Portfolio page it is: Portfolio without the / before the name of the anchor point. I don’t know if this makes a difference.

The truth is that it seems to me a very strange behaviour. It is the first time I see something like this and I have already created a few websites, although this is my second website with Sparkle.

I hope it’s clearer now what the problem is. You can see the strange behaviour from minute 1:40 onwards.

Mmm… The other day when I checked @Saeta things were going ok, but today I’m seeing what you are talking about - strange!

Things are taking way too long to load so it has to be something you have embedded in Sparkle?
So I went for a hunt… What is “Redux”?

Just checking the error console on you home page throws an absolute wobbler!
So I am sure this is your problem…

Thank you very much, Flaming.

I have no idea what “Redux” is, I haven’t put anything with that name on the website.

There’s nothing extra inserted either. The only “weird” thing is the animated “mouse scroll”, but it’s done entirely with Sparkle’s native animation capabilities:


The rest is Sparkle’s own video and carousel, the complex animation of the text balloon in the Reconnect section, also done entirely with Sparkle, and three more pictures.

On the Portfolio page I have embedded an animation made with Hype (Artesaeta_Logo_Animado). It is the only one that is an animation of my logo. The rest is all normal.

I have removed the “mouse scroll” and opened the web in an incognito window and it keeps repeating the problem…

Now I don’t know where to look. :face_with_monocle:

I only think of doing the whole web again but without knowing what is happening, there are many possibilities of repeating the error again… :grimacing:

Ok a strange one indeed!

Maybe I can suggest to FTP your account and remove all of your Sparkle website from your host and then get back into Sparkle and republish your entire site. That will make it a clean install and if it still plays up SOS Duncan…


I think this is an excellent idea as I have removed the mouse scroll animation and my logo animation and the error persists. Maybe there are some leftovers from the previous version.

I’ll make a clean publish and see what happens.

Thank you very much for your help.

I just checked the preview and everything runs smoothly and without problems, so it is very likely that the error is in the hosting, as you suspect.

I can’t fix it today, but tomorrow will be the first thing I’ll do.

I’ll keep you informed.

1 Like

Ok please send the project file to and we’ll take a look.

We’ll look at the project file, but testing the server a bit produces very inconsistent results, from long waits to errors even just for loading the base page html.