Button Issue When Website Live


I have created a website and seem to be getting an issue that I have never experienced before with Sparkle.

The issue I’m having with the site: www.apollowindowcleaning.com is with the Contact Us, Send Now & the Deny / Ok buttons.

When hoovering over the buttons they don’t do what I have set them up to do (as in change of colour) I have attached an example.

They do work correctly when I preview the site from Sparkle but when its is uploaded and live the issue happens.

Very frustrating and I just don’t seem to be able to establish why this is happening.

Appreciate any help :pray:

Hello :wave:t2:

It is displaying correctly for me. What browser are you using?
You can try clearing your cache, maybe the issue is coming from there…

Hi Allen

Thanks for your reply :pray:

I’m using Google Chrome on my mac & have also just cleared the cache but is still the same for me, not sure why as you can see it ok.

Is this how the button is supposed to appear when the cursor hovers over it?

The screenshot you see here was taken from Google Chrome :

Capture d’écran 2023-07-11 à 20.05.31

Yes that is correct and how it should be :+1:

This is really strange as I have now just tried on my windows laptop on Google Chrome and I’m having the same issue. I have also tried it using Safari on my Mac and still the same issue. This is very frustrating

That’s really strange, indeed. There might be an issue in the code, so I recommend sending your project to Duncan for him to take a look at it.

@StratBluesLC you have some strangeness going on here!

It looks like it comes down to how your browser handles SSL and javascript. Your placeholder page is throwing a lot of 401 errors (denied authorised access) and they are all “https” links. If you do have an SSL Certificate setup then it isn’t setup correctly.

On Android I don’t see the hover state issue that I’m seeing on the Mac desktop.

So I could suggest the following…

  • Reinstate your SSL Certificate
  • Remove your website from the server via FTP and Republish your Sparkle website in total


Yes it is as the original page created the button was working ok it is since the page was updated that the issue has started.

Thanks for that, I haven’t got a SSL certificate yet so unsure why they are showing as https links.

I’m a little out of my depth on this side of things and certainly with google search console. Trying to figure out what I have to do as i have verified the site but this morning I do have this & not sure how to fix it? :pray:

This could be due to a number of things @StratBluesLC
I myself have never had a soft 404 using Sparkle so this is a first.

A number of things could have caused it…

  • have you requested Sparkle to create Search Engine Metadata?
  • not enough content on your page
  • a time out error when the bots were doing their business
  • possible server configuration?

Have you cleared your site via FTP and republished it again? If not I would start with this first.

@FlaminFig @Allan thank you both for the help; I will look into that and hopefully can get it sorted.

Also have managed to sort the button issue out with the help of Duncan.

This is why I like Sparkle so much, its not just a great product but you also get great support from the community & Duncan :+1:


Great to hear! :slight_smile:
What was the issue with the button hover in the end?..

@FlaminFig the issue was that the site was set to a dark theme but I actually hadn’t made any adjustments to allow for that hence the issue happening.

Apparently Sparkle defaults to showing a light theme and my computer (and by chance so was all the other devices I tested on) was set to dark mode.

I disabled the ‘include dark colour theme in published site’ option within Sparkle and re-uploaded to my server and issue was fixed :+1:


Oh wow! Well I have learnt something new!
Thanks! :slight_smile:


I would have never thought to check the dark theme! Thank you for your feedback, @StratBluesLC, good to know!

1 Like

This has been a head-scratcher more than once, we should find a solution. The preview can be configured to show the system theme instead of the one currently active in the canvas, but like for device layout it would be very confusing to have that as a default.

1 Like