Email form issues

Hi Duncan,

I tried several times, with several form, I can’t get any form to get to my mailbox… :confused:
I tried with a few email I even checked the “spam score”…
Hope you can help me :slight_smile:
Thank you!


So, the settings look correct to me.

The only thing I can think of why it doesn’t work is the email “”. Maybe this is blocked globally as nonsense.

Replace it with e.g. “” and test again.

Mr. F.

1 Like

Thank you! Did it, but unfortunately… still the same issue.

Just examining the obvious - have you defined a “thank you” page and does it have the .php extension rather than .html? Form submission will not work without this.

Very rarely, the host php version can be out of date, too.

1 Like

Ohhhh! The obvious, never underestimate the obvious!
Well done! Thank you!!! Soooo there was NO thank you page.
Did it, indeed it’s a .php But the page will remain “blank” and no e-mail is submited.

Could you try setting up this to troubleshoot:

  • go to
  • get an email address
  • set that email address in your “recipient” field
  • publish your site again
  • send a test contact form
  • go back to the page and view the results (and share the page link)
1 Like

There are a couple of threads here with the same problem.
Maybe the reason for the malfunction is hidden in your webspace. The host is … ?

Mr. F.

1 Like

If if test my own address → Spam Test Result
But if I put the email I get from mail server into recipient, as the form won’t work, I don’t get anything from mail-tester.

There’s no point in putting your own email address, the contact form goes through the server.

So my guess is Scaleway is either blocking outgoing email entirely, or has specific restrictions on how to enable it.

Another configuration possibility is to set the email delivery not via the server, but directly to the SMTP server:

CleanShot 2022-09-16 at 08.38.38@2x

The server, username and password here would be exactly the ones used by Apple Mail on your Mac.

Since you’re delivering directly to the mail server, the recipient address should be like it is in the first screenshot.

1 Like

Even if I go through SMTP configuration, I’m still stuck at the blank (full white actually) page after clicking “SEND”.
Will switch to “please send an email to x@x.x” until I find the correct way.
Thank you all for your help.

Did you check the documentation?

Mr. F.

1 Like

I did, all my devices send/receive e-mails (from several serveurs / hosts).
Will start from scratch (in a few days) and let you know. Thank you!

@Papain, sorry to hear you are having a tough time with this, but your explanation of what happens doesn’t seem to be the norm. Could you explain to us what you are actually doing after you have created the form… starting with clicking on the SEND button.

1 Like

As mentioned, you need to contact Scaleway and ask about your website sending email.

1 Like

I started from scratch another form.
Still not working with Scaleway, but works like a charm with OVH and Hostinger.
So… as some of you said, « blame it on the host » :slight_smile:
Thank you all for your fast answers and your patience!!!
Merci !

EDIT : Scaleway support was great. Indeed my php was out of date.