Failing to publish to disk and ftp

Sparkle is failing to publish to disk and ftp on sites that have always worked fine.
I don’t get any further info than “publish error. Export to disk”
Publishing to ftp gets around a third of the way through and then fails and viewing via an ftp app shows most files have uploaded.
In addition Sparkle will sometimes say it’s not connected to the internet at all and sometimes will try and fail. Have rebooted several times etc.
It’s been a while since I last published but I think it was before I upgraded to Sonoma so is that the issue although there is no reference to problems on this site?

My first thought would be a poor internet connection!
Have you tried rebooting your router?
Try running


Thanks but that was of course the first thing I tried - connection is 100%

I think perhaps it’s a font called Hanken Grotesk but it’s not one used in the website and not on the font list all, and I don’t see how to delete it.

Check the Folder you attempting to publish to—is it the right path?

@DerekG it might be best if you use the “Send Sparkle log via email” in the help menu, so that we can take a look at what might be going wrong.

Above and beyond as usual!

I sent Duncan the log as requested and after a bit of back and forth over email he found the problem and sorted it.

A quite remarkable level of support and an amazing app.

1 Like

could you please explain for others what the problem was?
It’s very appreciated.

Some variable width fonts conventionally have the list of variable axes included in the file name, so for example the built-in Hanken Grotesk file name is something like HankenGrotesk[wght].woff.

What I assume to be some security layer on @DerekG’s web host was preventing files with the %-escaped variant of the name to be uploaded, giving a generic error.

The fix was to replace the square brackets with a safe character.

This is unlikely to affect anybody else, as it’s the first time we find this in 10 years of Sparkling…

1 Like