First upload help to publish after iweb

This may be obvious to everyone else - I am trying to publish for the first time to the internet on sparkle.

Previously root folder is configured on iWEB - do i need to delete all the files first on host site?

I have the FTP user details etc - getting stuck at root folder step.

Any help gratefully accepted,

Cheers!

Are you hosting your website on a ‘traditional’ hosting plan i.e is it on a linux server, and what is your website address going to be e.g https://www.mywebsite.com and what was your old website address?

If you are hosting your site as suggested above then If it were me I would have a good clear out before uploading a new sparkle website to it.

But be careful what you delete!
in the public_html folder there will be a cgi-bin, whatever you do DO NOT DELETE THIS - sorry about the caps but it is a warning :slight_smile:

Any other files and folders such as index.html and subfolders from the previous iWeb can safely be deleted.

I have never used iWeb so I don’t know how it hosts the files etc. Maybe someone else can also suggest some help in this regard.

Best
Scott

Thank you so much Scott,

yes i have a LINUX server and it is the same URL address as before…

I have deleted the files in Homedirectory>HTTPdocs

yikes hope i haven’t deleted the cgi-bin I can’t see it there!!!

When trying to publish, I enter in all the FTP details, connect and get:

The selected folder is not published.

Do I need to manually add an index.html or new folder on server (have tried this, no luck)

As Duncan will say at times the hosting servers can be a bit tricky?
This is how I have set one up for one of my clients… I’m using a subfolder called “/dev”…

Going about it this way (plus I have SSL on all my clients hosting accounts) I always seem to have success!..

1 Like

Thank you! So do you then also set the sub folder up on your server?
This is what I get…!

@gbolton, Have you tried just to ask Sparkle to go “Next”?

I use slightly different config when uploading through sparkle and it works every time for me. I have an SSL certificate on this hosting plan.

On my server Sparkle will publish to the public_html folder as shown below…

so after publishing with Sparkle inside the public_html folder is where all the uploaded files are located…

Yes @greenskin it just goes back to the error msg…

@gbolton, You should be placing your website under “public_html”. Try that and if Sparkle errors, push it pass that by going “Next”…

hmmm ok I don’t seem to have the public_html folder option…

It is hosting through ‘domain central’ (provider)

@gbolton, Ok just to make sure… are you hosting with a hosting provider and do you have access to a cPanel which is the interface to your hosting package. Or are you self-hosting?

Yes ‘domian central’ is my hosting provider and I have a control panel
domaincentral.com.au

I think if you are trying to publish to httpdocs then your web address would be http://mywebsite.com but if I’m not mistaken if you try and publish to http://www.mywebsite.com then the public_html folder is an alias for the ‘www’ part of you website address.

I think that is correct, my apologies if it is misleading information.

@gbolton, Ok strange then. With @rimram help I’m sure we are close but maybe @duncan can take a look and help your further? It might be something we have missed!..

@gbolton Any luck in sorting this out?

Best
Scott

Thanks so much guys, yes finally sorted. There was an issue with the host (server pointing to wrong location/IP address in the changeover) Thank you for your willingness to help much appreciated :slight_smile:

1 Like

That’s good news! Great that you are up and running :smile: