Home page doesn’t default to mobile…

I have built a 3 page site using sparkle, and I followed the help docs to figure out how to make a desktop and a mobile version. When I preview the site, everything looks good. But when I view the live site on my phone, the home page will not display in the mobile version. It’s always the desktop version.

Any ideas?


after you have build your desktop website in 920px or 1200px you need to create a 320px version and align all your text and pictures on it.
320px is that version what a mobile phone use.
Be aware, iPads do not use the mobile version, iPads use the desktop version.

When you click PREVIEW, there are 2 choices. Have you tried the second one which includes mobile? And is your phone on your local WiFi network, the same one that your iMac is on?

This is not normal Sparkle behavior, so something specific to your website. We can take a look if you want to provide the address of the site.

That’s very kind. Here is the url: https://helpfulmarriage.com

Yeah, I have the second choice, “all devices”, selected. I was using the QR code to test out on mobile.

The site looks fine, including on mobile (mobile layout there). My guess is your phone might have cached an earlier copy of the site perhaps? You can try a different phone, or go to the system settings to clear the cache (on an iPhone that’s in the Safari section of the settings I believe).

DNS caches are so annoying…


Thanks very much!