Odd thing after publishing

I published my blog this evening and noticed an odd thing.

My about page should look like this:

but after publishing, the About Yumcha Mama is not showing (as per the image below). All other pages styled in a similar manner are fine.

I’ve played with the placement etc but no luck.

Any ideas??? Sorry again for the barrage of questions! I’m so embarrassed!

Could be any number of things:

  • multi-device setup where the text is out of place on the layout you’re looking at
  • browser cache
  • server cache
  • broken upload

If you share the address we could look at any issues on our end and maybe draw some initial conclusions from that.

Thank you so much Duncan. I noticed after writing that it’s two pages - the second one being based on a duplicate of the About Me page.

The link to the page in question: HERE.

Thank you ever so much!!!

In Safari, my guestbook, that was initially visible last night, is now blank. In Chrome there’s no issue.

Any thoughts?

This is happening because of blocking. Your guestbook is on an unsecured folder of your website, whilst trying to display in a secured page on your website. You should ask your host to ensure that the HTTPS is applied to all subfolders of your domain. They can do this by making a change to your htaccess file.

It may be that you may have added the website address to the script somewhere either during installation or somewhere in the back-end admin area. If so, you should ensure that you alway use the HTTPS designation in the URL. Although the script itself will still work, it will pull the script from the non-secure URL, which is probably what is causing the issue. If you don’t want to reinstall the script, just ask your host to override the block through htaccess. You can see the problem in the source code of the page:

<iframe src="http://www.yumchamama.com/guestbook/preview.php" frameborder="0" scrolling="auto" width="100%" height="1200"></iframe>

1 Like

Still not working for you? They work fine from here.

1 Like

Strange, I couldn’t see it in Safari or Chrome - maybe its something to do with security settings in the browsers. I have seen this problem before and it was always sorted by allowing non-secure content to display in a secure page, as suggested by the error message in the console.

1 Like

@jazzbird, From my take on it it is definitely a “https” conflict (like what @francbrowne is implying), because when I force your domain to display “http://” I get the guestbook to make an appearance.

Need to update your iframe to read “https://www.yumchamama.com/guestbook/preview.php”.

1 Like

Sorry I was referring to the original post and screenshots, the missing title.

1 Like

Thank you ever so much @francbrowne and @greenskin! I have done as you have suggested and am now republishing. Fingers crossed!

@duncan, I was at a loss as to what I had done wrong (I know it’s something from my end) so I went back this evening and inserted another wide box and then the wording again over it. But thank you for your help earlier. Much appreciated!

@duncan, I just checked in Safari and Chrome again (I wasn’t able to check earlier after republishing) but it’s still not showing. It’s rather bizarre. It’s just the About Me page (the guestbook wording is okay).

@jazzbird, Checking your site the “About the Yumcha Mamma” is definitely there where you say it is, but you’ll need to bring it to the front on the Sparkle canvas. It is at the moment sitting behind the widebox.

1 Like

Thank you again @greenskin! It’s so odd as I kept bringing the words to the front and on Sparkle and in the preview it looks fine. I tried again and just The Yumcha Mama displayed. I’ve now sent the wide box to the back and republishing now.

It’s finally working! Phew! Thank you again to all! :smiling_face_with_three_hearts:

1 Like