Preview not working

Hi all, due to the fact my old tool Sandvox from Karelia Software is no longer running with the latest update of macOS, I switched some days ago to Sparkle Pro.

Now I’m facing a problem, I can’t solve even searching in this community: When trying a preview I’m just seeing a white page in my browser (I’ve tried Firefox, Chrome and Safari - it’s all the same). When I’ve used the 14 days free of charge version, I’ve received at the top of the page “This was generated with a free of charge version of Sparkle” (or similar in German).

In addition I’m quite surprised about the IP shown inside the window. It’s totally different to the one of my iMac.

Thanks in advance for your support &

Greetings from the north of Germany!

Hello and a warm WELCOME :slightly_smiling_face:

Do you have “all devices” marked when you go to the preview?
And which devices have you set?
And from which device (Layout) do you go to the preview?

Sometimes screenshots of the settings help us to see more.

Mr. F.

1 Like

Hello and welcome Olaf ! :blush:

The IP address used to preview the site is the private and local IP address, and not the public IP address. You can check your private IP address in your Mac settings, under Settings > Network > Wi-Fi or Ethernet.

The time I had this problem of a white page was because of a duplicate, I had two different versions of Sparkle installed on my Mac. A regular version and a beta version. But I don’t think that’s your case…

1 Like


Maybe yes. He had the 14 day free trial running and now he’s on the pro Version.
@Olaf should get in touch with Mr. Duncan.

Mr. F.

Do you think so? The free version and the pro version are two different software? It’s not just a matter of license?

But indeed, if he has two installed Sparkles, it could come from that.

Hi, that’s the solution! I need to add the other devices with “automatic scaling” and to choose “all devices” when starting preview. THANKS!!!

Allan, thanks…

The IP of my iMac is (I know, I know 192.x.y.z isn’t optimal but working since mor than 30 years!) while in the Preview window is shown. That’s confusing me a little bit.

Hi, thanks and see below…

Funny, that I can’t change the device (layout). Quite sure, it’s my mistake because I’m too blonde.

Btw: I have exactly 1 version of Sparkle installed.

Greetings from Germany!

@Olaf, you have selected “auto scaling” on all your devices except PC. When you have auto scaling selected Sparkle does the work and that is the reason why you can’t access the layouts.

Have you checked how your 320 device is looking?
I would strongly advice in not auto scaling your mobile device and manually tweak the layout and its content to give your Users’ a better mobile experience.

Hi Olaf.

Oh, WOW - that’s the wildest setting i’ve seen in Sparkle. Having 6 layouts does not mean to use them all. Less is more!

And as FlaminFig mentioned, your font sizes go crazy. I have tried a couple of settings and ended with this:
1920: n.a.
1200: auto
960: custom (3 columns)
768: auto
480: n.a.
320: custom (1 column)

Do you know that there’s a video tutorial channel on Youtube?

Mr. F. is always the address of the computer to itself, so called “localhost”. That’s the IP shown when you have selected the “This computer only” preview availability. In other words the preview won’t be usable from the local network, which is something you probably prefer if you’re in an office or coffee shop. If you switch to “Computers and mobile devices on the local network” Sparkle will then open preview access to other devices by exposing the preview service on your network IP.

thanks for the link with the tutorial from Duncan. I think, it will enlighten me (at least a little bit).

At this moment, I’m facing another problem. In preview the sub-menue-button is missing and the text as well. I need to figure out the reason…

I will check your settings.

Alright Sir.

Can it be that you made both invisible for this device? So, in preview you will not see them.
The small eye symbol makes me guess that.

You can undo this under “arrange”

Mr. F.

I have no idea, why. I just started a new Sparkle project and now everything is fine. Now I will learn and try. I fear, I’ll come back soon with a lot of questions.

First one: Why I’m not able to delete a chapter (I hope that’s the English word for “Abschnitt”?

To delete a section (Abschnitt), you need to hover over the section name and then click on the small cross that appears next to it