Small .png images generated by Sparkle

The font is Verdana. And in any case I am viewing it on my own screen, so it’s nothing to do with other users.

Cheers,
Ian

@ianrid
@greenskin

Ah! So it is a font issue …
The font should be Verdana, but my Safari version uses Geneva instead (from the font stack in the CSS file). I have Verdana installed and activated … but Safari doesn’t use it.

So that’s why we have this difference …

Newer versions of Safari don’t like certain “system fonts” because they are deemed “unsafe” (because of tracking) … Duncan wrote about this some time ago in this thread:

1 Like

It seems as if your zoom in and out shortcuts are set to a non-standard key combination. The default settings in Mac are command + for zooming in and command - for zooming out. On your system you have command Ä for zoom in and Command Ö for zooming out. However, the make text bigger and smaller options use the default + and - but with the addition of Alt Command. This may be what is causing the issue. There is no option in Mac OS to change the default zoom in and out shortcuts so it maybe that if you use those shortcuts, its triggering the make text bigger and smaller options.

It is possible that you have set up zoom options in your accessibility preferences. Doing this will override the default zoom functions in OSX. If you have this option selected, you should try deselecting it and then try your default zoom functions of command + and command - again to see if that does the trick.

@francbrowne

Thank you for your time and explanations. :+1:

It is correct that I have set up my own keyboard shortcuts for certain menu commands.
I use a MacBook Pro with a Swiss German keyboard layout, that varies greatly in some areas compared to a standard US keyboard, so some of the default macOS key combinations just don’t work for me or are too inconvenient unless you want to break your fingers. :grinning:

I checked my keyboard shortcut settings but strangely enough I don’t find any personalised shortcuts for the “Zoom” options.
However … as I mentioned before, I suspect an old preferences file. Ah well, I’m too lazy to look for that now and I’m not really bothered that these two options show up under the “View” menu in Safari. :slightly_smiling_face:

I guess it will be time to do a clean install when macOS Big Sur will be released … :+1: :smile:

Dear Franc,

Did you have any further thoughts about the font scaling problem I reported on Safari? (We got rather diverted by the discussion with Shadowfax about Menus) I have reproduced it on multiple devices, and it affects your own pages as well as mine, as in the screen shots I posted above. The rendering in Firefox is rock solid, so it seems that it is a result of how Safari renders your code. Needs to be fixed as it must be affecting other users as well.

Cheers, Ian

@ianrid
Hi Ian, I don’t think the screenshots you provided were from my site - I don’t have a site with such content. However, there could be some issues with the way Safari is set up on your system. The problem is we can never predict how people will have their browsers configured. If you want to test one of my sites, you could check out THIS ONE or THIS ONE and see how they render in your browser. Admittedly, these sites are not 100% Sparkle - some pages are, some are not. But it should give you an indication if you have a browser problem or if it’s a site problem.

Let me know how it goes

Dear Franc,
Apologies – I thought you were part of the Sparkle operation. Please ignore the previous message.
I will have to aim my message at Duncan instead!
Cheers,
Ian