Snap! Help! Text block adjustments

So sometimes I’m moving some text in a block around the screen and it has a little “stop” as it approaches a new text block. However, sometimes it doesn’t do the little “stop” and just runs over the next text block smoothly.

This feature can be both useful, and annoying depending on need.
How do I turn this feature on, or off please - there must be a setting that I can toggle?

Please help and many thanks for reading.

If you press tab to hide the snaps then the elements won’t snap. Also while dragging you can hold the ctrl key to disable snap just for that drag.