Publishing to server on local network

I have two computers on a LAN, I create a Sparkle website on one and want to publish it to the other. From the one I use Sparkle on I can successfully connect with FTP, via a terminal window, to the other computer. When I try to set up Publishing in Sparkle I use the LAN IP address of the receiving computer in both boxes of Web address and Server. I have tried to publish to both /Public and to /tmp. Something is probably wrong because I get the message ‘The selected folder is not published to’.
Any suggestions as to what the correct Web and Server names should be?

Sparkle is attempting to ensure your FTP space is actually published at the web address you specified in the settings. Is it?

No. I select a folder from the displayed list and create a new folder, then hit the Next button. The message about not being published pops up and inspecting the specified web address shows that the new folder was created but that folder is empty.

The folder you need to pick is whatever the web server is configured to. You can’t really make up a folder because Sparkle doesn’t have access to the server configuration, it’s just trying to discover it.

The folder defaults to / and the only folders I have a choice to select are those in my home directory. I can’t type in the web server folder in the Current path box, which in my case is /var/www/html.
If I select a new folder is just creates one in my home directory.

I don’t really know how else explain it. There’s no option to enter the path directly, you need to navigate the filesystem and find the root /, then var, then www, then html, and select that folder.

There is no way to navigate the filesystem. The default is / and cannot be changed, but any another folder selectable, whether one that is listed, or even created new end up in the home directory of the User typed in in the publish window.
Do I need to create a user on the target computer that has the webserver directory as a home directory in order to get the chance to select a target folder for the publish?

So if you can’t navigate the file system it probably means it’s an FTP server configuration.

What do you mean ‘navigate the file system’?
The Publish process doesn’t let me navigate the filesystem. It starts me in the home directory of the User that is required in the Publish setup and you can’t go to anywhere else.

Navigate the filesystem means clicking from one folder to the other.

I think this is exactly the problem. This is not a Sparkle issue at all, it’s the server that’s not configured to give that particular FTP user access to the place where the public html lives.

What you need is to get the server properly configured, but frankly this is beyond the scope of Sparkle and the support we are able to provide.

Thanks duncan. It start to make sense now. Sparkle connects to the ftp server, but since the User I used in the Publish process does not point to the html directory Sparkle does not show the folders there that can be selected for Sparkle to publish to.

What exactly is Sparkle looking for when it tries to publish to the web?
The / directory it starts with defaults to the User Name’s home directory.
There is no way to point it to the web server’s directory .

I have configured a User Name to be the owner of all the directories to the web server’s html directory/folder. In the Publish setup I create New Folders for each the directories .
The Publish to Folder string looks correct (ie., /var/www/html) which is where the web server gets the files to process. The publish statement still pops up about not being published.
That is why I want to know what exactly is Sparkle looking for.

Sparkle publishes a small file with a random name via FTP, then looks for the same file at the web address you indicate when setting up. So it’s just what it sounds like, a match of the FTP folder with the public web-viewable folder.

If the folder is correct, and Sparkle can write to it via FTP, and the server doesn’t have weird caching things, it will be immediately visible via http.

You will eventually face this problem anyway, so you can jumpstart it by writing an index.html via FTP yourself, and seeing if the server shows that. This is (very) basic server setup troubleshooting, which is again not the scope of our support.

Thanks Duncan for all your patience and help. I finally got a valid Publish to the Web after tweaking the folder/file permissions, but one anomaly still plagues me.
The little left/right arrows that are present when creating an image gallery web page (and work when Previewed) do not appear in the published page.
Is this a condition that is known to happen or have I missed something?

Perhaps you can publish the site to a live site so I can take a look? The images are there generally.

The IP address you need for the url is is my router ip and http should be forwarded to my computer that is my web server.

After looking at it again in the create mode and then Previewing it, the left/right arrows are no longer there.

@cearlp, Just make sure the left/right arrows don’t hang over the guidelines of the device width.

Could you please send the project file to and we’ll take a look. I can’t really figure out why it’s not working by looking at the published site.